+49 (30) 467086-20 service@microtool.de
Products » objectiF RPM » User interface and how to work with it » Workspace » Create, Edit and Delete Projects

Create, Edit and Delete Projects

For administrative reasons, projects and project templates can only be created by a user with Database Administrator or Organization Administrator permissions. Modifying or deleting projects also requires administrative permissions.

Create projects

Projects are created in the Userboard via the context-specific menu or within an organization. You can use one of the included project templates as a basis, or import a suitable template from the project catalog.

To create projects, you must have at least Organization Administrator privileges. If you do not have the necessary permissions, the New Project command will not appear in the context-specific menu or will be disabled.

Open context-specific menu

Create project using the context-specific menu

  1. Open the context-specific menu from the Userboard and select Create → New Project.
Project Creation Wizard - Step 1
  1. In the Create Project dialog, first enter a name and a short identifier.
    The short identifier will later appear in the automatically generated IDs when requirements, test cases, etc., are created.
  2. Make sure that the Create as Template option is not selected.
  3. Select an organization under which the project is to be created.
  4. Next, select a project template. On the Project templates tab, you’ll find templates provided by objectiF RPM by default. Using the File tab, you can use an exported project as a template, and using the Catalog tab, you can import and use a project template directly from the cloud.
Tip
You can save projects that you want to reuse as project templates in the form of SXMI files. To do this, open a project and select Project → Export → Export to File from the context specific menu. You can then select the exported project as a template for a new project via the File tab.
  1. Click on Continue.
  2. In the upper section of the subsequent dialog box, you can use the calendar to specify a start date.
  3. Replacing the placeholders is optional.
Project Wizard - Step-2
Hint
You can extend and adapt the placeholders.
  1. Click Create to create the project. If you mark the option Open, then the project will be opened straight away.

Create project in an organization

Projects can also be created within an organization. The project is then always assigned to the organization in whose context the command was invoked.

  • Richt-click on the background of the Explorer window and select Create → New Project from the context menu.
  • A dialog will open with the same options as described above, but the new project will be allocated to the organization in which the command was executed.

Open project

Click on the project tile in the userboard to open a project. There are also other ways to open a project.

Hint
Users cannot open a project until they are assigned to that project.
Open project in the userboard

If you are in the userboard, simply click on a project tile.

open project
Open project via dashboard
  • Go to an organization and open a daschboard f.e. via the topic bar.
  • Click the Open Project button.
Open project in an organization

If you open the Explorer window within an organization, you can also open a project via the Open Project context menu.

Open project in the roadmap
  • Go to an organization and open the roadmap via the topic bar.
  • Select a project milestone and click the Show Project button

Edit project properties

Project properties include, for example, the name, the short code, the stereotype, a description, and the project status, which are specified or automatically generated when a project is created. The following properties can be changed later:

  • Name – specified upon creation
  • Short code – specified upon creation
  • Stereotype – generated automatically
  • Region – can be assigned later (optional)
  • Status – generated automatically
  • Description – automatically taken from the template
  • Delete project – set automatically
  • Project tile color – set automatically
  • Font and font size – set automatically
  • Automatic return of documents – can be set later (optional)

If you want to change these later:

  • Open the project whose properties you want to change.
  • Go to the context-specific menu and select Project → Properties.
  • Save the changes by clicking OK.

Delete project

Projects can only be deleted by users with administrator rights, such as the database administrator, organization administrator and the project administrator.

Hint
As of version 7.5.1, the Delete command is deactivated by default to prevent accidental deletion.
Cancel deletion protection
  1. Open the project you want to delete.
  2. Go to the context-specific menu and open the properties dialog by clicking on Project → Properties.
  3. Switch to tab Settings and deselect the Allow deletion of the project option.
    The command in the context-specific menu is now enabled, and you can delete the project.

Delete Project

  • In the context-specific menu, click the Project → Settings → Delete command.
Delete Project via the context-specific menu

A confirmation message will appear when the project has been successfully deleted.