+49 (30) 467086-20 service@microtool.de
Produkte » objectiF RPM » Service-Manager starten » Neuen Service anlegen » Service starten und am Client anmelden » Fehlermeldung beim Starten eines Services

Fehlermeldung beim Starten eines Services

Wenn Sie keine ausreichenden Berechtigungen besitzen oder die Anmeldedaten nicht übereinstimmen, kommt es zu Fehlermeldungen und der Verbindungsaufbau wird abgebrochen.

Fehlermeldung
Fehlermeldung Keine Verbindung zur Datenbank
Ursache und Lösung

Ursache

  • keine Berechtigungen, um auf eine Datenbank zuzugreifen
  • Filestream wurde im SQL-Manager nicht aktiviert

Lösung

Aktivieren Sie den Filestream-Zugriff im SQL Server Management Studio und starten Sie dann den Dienst neu. Bekommen Sie weiterhin keine Verbindung zu Ihrer Datenbank, überprüfen Sie, ob das Systemkonto von Windows weiterführende Rechte am SQL Server hat. Der Service-Manager läuft standardmäßig über das Windows-Systemkonto und benötigt daher diese Rechte.

Überprüfen Sie Ihre Berechtigung im MS SQL Server Management Studio unter Sicherheit/ Anmeldungen. Markieren Sie das Kontrollkästchen sysadmin.

Berechtigung aktivieren

Wenn Sie nicht die Windows-Anmeldung verwenden wollen, legen Sie sich über das MS SQL Management Studio unter Sicherheit/ Anmeldungen eine neue Anmeldung an.

  1. Selektieren Sie den neuen Benutzer und öffnen über das Kontextmenü den Befehl Eigenschaften.
  2. Markieren Sie unter Serverrollen die Rollen public und sysadmin.
  3. Öffnen Sie anschließend die Windowsdienste über Systemsteuerung/ Verwaltung/ Dienste, suchen den Service-Manager und weisen über das Kontextmenü Eigenschaften/ Anmelden/ Dieses Konto das angelegte Konto dem Dienst zu.
Fehlermeldung 
Fehlermeldung Nutzer ist deaktiviert
Ursache und Lösung

Ursache

  • die Serverauthentifizierung ist deaktiviert

Lösung

Ist die SQL-Installation selbstständig durchgelaufen, müssen Sie die Serverauthentifizierungsmodus nachträglich umstellen. Markieren Sie das Kontrollkästchen Aktiviert im MS SQL Server Management Studio unter Sicherheit/ Anmeldungen/ Status.

Serverauthentifizierung aktivieren

Fehlermeldung
Fehlermeldung Falsche Logindaten
Ursache und Lösung

Ursache

  • Passwort und Benutzername stimmen nicht überein

Lösung

Befinden sich SQL Server und objectiF RPM Server auf unterschiedlichen Rechnern, müssen Sie dem objectiF RPM Server ein Anmeldekonto einrichten, das vom SQL Server akzeptiert wird. Öffnen Sie das Windows Dienste-Fenster, wählen den objectiF RPM Server und öffnen über das Kontextmenü den Menüpunkt Eigenschaften. Tragen Sie die Anmeldedaten auf der Registerkarte Anmelden ein.

Anmeldedaten für den Server ändern

Fehlermeldung
Service ist nicht gestartet
Ursache und Lösung

Ursache

  • Im Service-Manager ist der Service nicht gestartet.

Lösung

Öffnen Sie den Service-Manager und starten Sie den Service. Warten Sie bis er grün ist. Ist der Service grau, wählen Sie im Service-Manager den Menübefehl Services konfigurieren/ Dienst starten.