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Products » objectiF RPM » Launch the Service Manager » Create new service » Launch service and log in to client » Error message when launching service

Error message when launching service

If you do not have the required permission or if the login details are not correct, an error message will be displayed and the connection will be cancelled.

Error message

Cause

  • No rights to access this database
  • Filestream is not activated in SQL Manager

Solution

Activate Filestream access in SQL Server Management Studio and re-launch the service. If you can’t connect to the database, check if the Windows account has the appropriate rights to the SQL server. The service manager runs through the Windows system account by default and therefore requires these rights.

Check your account rights under Security/Login in MS SQL Server Management Studio. Check the checkbox sysadmin.

If you do not wish to use the Windows login, then create new login details in MS SQL Management Studio under Security/ Login.

  1. Select the new user and open the command Properties in the context menu.
  2. Under server roles, check the roles public and sysadmin.
  3. Then open the Windows service via Control Panel / Mangement / Services, search for the service manager and allocate the new account to the service with the context menu Properties / Login / This account.

Error message

Cause

  • Server authentication is deactivated

Solution

If the SQL server runs by itself then server authentication must be changed afterwards. Mark Activated in MS SQL Server Management Studio under Security / Login / Status.

Error message

Cause

  • Username and password do not match

Solution

If the SQL server and the objectiF RPM server are on different computers, then you have to set up a login account that will be accepted by the SQL server. Open the Windows service window, select objectiF RPM server and open the menu item Properties in the context menu. Enter the login data in the tab Login.